Back to overview
Up and running again.
Apr 21, 2026 at 7:44am UTC
Affected services
freshnrebel.com
Resolved
Apr 21, 2026 at 7:44am UTC
Maintenance is done. Will be up and running in couple of minutes.
Affected services
Resolved
Apr 21, 2026 at 7:44am UTC
Maintenance is done. Will be up and running in couple of minutes.
Affected services